cancel
Showing results for 
Search instead for 
Did you mean: 

No webhook events have been received for: Default Store View (Live Mode) - Please ensure that your w

No webhook events have been received for: Default Store View (Live Mode) - Please ensure that your w

Is there a way to fix the issue on "No Webhooks events" for Stripe?
https://prnt.sc/lNIv8wRrVxM9

Because I need to manually click on the "Configure" button on the Payment Method -> Stripe -> General settings.

https://prnt.sc/ysHWjekaR_dJ

 

I also checked if my CRON jobs are running but on the CLI, the command "crontab -l" returns empty on the terminal.

1 REPLY 1

Re: No webhook events have been received for: Default Store View (Live Mode) - Please ensure that yo

Hello, I had the same issue for years and could not find a clear solution any where online but it seemed to be a non issue because everything was working correctly. It was just annoying to see that message every time I logged in to my admin account. I decided to revisit and try to get rid of the message so this is what I did that worked for me;

I logged into my Stripe account and deleted all my webhooks, I actually had more than one.

Then I logged into magento admin account, went to Stripe Configuration, made sure my Live Publishable API Key and Live Secret API Key from Stripe were correct and then hit the configure button next to Webhooks. This automatically created a new webhook in my Stripe account and got rid of the annoying message for good.

I think the problem was that initially I manually entered my webhook address in my Stripe webhook section before I hit the configure button in magento. This is why I had more than one webhook, one I created and one was created automatically by magento. In order for the webhook to work correctly it must be created by the Webhook Configure button in magento.

I hope this helps.