cancel
Showing results for 
Search instead for 
Did you mean: 

changing root: No input file specified.

SOLVED

changing root: No input file specified.

Hi There,

I'm using Apache 2.4 server from Godaddy.

 

However I want to change the root of my domain to be pub instead of public_html.

I've follow the method in the following link :

https://webfiredesigns.ca/blog/how-change-documentroot-whmcpanel

 

After that I put following command :

bin/magento deploy:mode:setSmiley Tongueroduction

according to following instructions :

https://devdocs.magento.com/guides/v2.4/install-gde/tutorials/change-docroot-to-pub.html

 

My problem is now when I refresh my website the following error appear :

No input file specified.

 

Is there anything else should to be done ?

 

Looking forward for your kind assist.

 

Best regards.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: changing root: No input file specified.

Hi there,

 

It's solved after update doc root of PHP-FPM file according to following link: https://support.cpanel.net/hc/en-us/articles/4403256459543-How-to-update-the-PHP-FPM-document-root-f...

View solution in original post

6 REPLIES 6

Re: changing root: No input file specified.

Hello @infonectar9054 ,

Not sure what you have done so far, you just needed to make one small change in server file below :

sudo nano /etc/apache2/sites-available/YOUR_WEB_DOMAIN.conf

 here it must be pointing to your project folder, you just need to add pub after that.

save the file, re-enable the website configuration and restart the apache server.

if you have set pub/static/ and pub/media/ path somewhere in magento, you need to change that to static/ and media/.

Hope it helps ! Let us know if issue persists.

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !

Re: changing root: No input file specified.

Hi @gaurav_harsh1 

The file you mentioned (mydomain.conf) is empty !

Re: changing root: No input file specified.

This error is usually produced by incorrect directives in either the php. ini or the . user. ini files for your website.  GoMedicare Cost

Re: changing root: No input file specified.

Hi @melindaeti529b 

Still not working.

Re: changing root: No input file specified.

Hi there,

 

It's solved after update doc root of PHP-FPM file according to following link: https://support.cpanel.net/hc/en-us/articles/4403256459543-How-to-update-the-PHP-FPM-document-root-f...

Re: changing root: No input file specified.

In the account Dashboard, select cPanel Admin. In the cPanel home page, select Domains and then select Addon Domains. Under Modify Addon Domain, next to the domain you want to change, select the pencil. Enter a new document https://writinguniverse.com/free-essay-examples/humanities/ root, starting at your home directory, and then select Change.The root directory is the folder that is accessed when internet users type the domain name of a website into the search bar of their browser.