cancel
Showing results for 
Search instead for 
Did you mean: 

conflicting component dependencies in Magento 2.3.0

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

Hi, I have the same problem.  Did you find which .htaccess and .ini should be changed?

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

Adjusting the memory values in .htaccess and .user.ini worked for me.  Thanks for everyone's work into fixing this issue.  I would have never found this myself.

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

I've tried everything in this thread and it still doesn't help, I'm running Magento 2.3.2 with Agentotheme and my composer.json files contains a different require-dev and if I remove all of it I get another error. PLEASE Help!

 

},
"require-dev": {
"allure-framework/allure-phpunit": "~1.2.0",
"friendsofphp/php-cs-fixer": "~2.13.0",
"lusitanian/oauth": "~0.8.10",
"magento/magento-coding-standard": "~1.0.0",
"magento/magento2-functional-testing-framework": "~2.3.14",
"pdepend/pdepend": "2.5.2",
"phpmd/phpmd": "@stable",
"phpunit/phpunit": "~6.5.0",
"sebastian/phpcpd": "~3.0.0",
"squizlabs/php_codesniffer": "3.3.1"
},

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

I have found editing composer.json and removing these lines fixes the problem.

 

       "magento/magento2-functional-testing-framework": "~2.3.14",

        "pdepend/pdepend": "2.5.2",

        "phpmd/phpmd": "@stable",

 

Does anyone know if this will cause a problem?

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

This worked for me. I also had to do it in both places  .htaccess and .user.ini

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

If you are running Nginx with php-fpm, you can solve this issue by editing your php-fpm www.conf or pool conf files and add the following:

 

php_admin_value[memory_limit] = 2G

 

I also changed the hardcoded memory and execution times set in the nginx.conf.sample file.

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

Hi daniel, i believe your solution has helped some many people but am still stuck here, I do not really know much about php. where can i find the php.ini file and am only use to the magento admin platform. 

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

this solved my problem

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

same problem we are facing

We found conflicting component dependencies in magento 2.3.1

help me what should i do....

123.png

Highlighted

Re: conflicting component dependencies in Magento 2.3.0

i feel your pain.

i've tried for a week to get this resolved.

it's broke everywhere.

about to give up and move on to another platform, it's not even funny anymore.

this is a huge problem and it's been around for awhile with no real answer and no real fix.

what works for some doesn't for others.

magento blames server settings and hosting providers blame magento.

it's sad that this garbage gets put out there.