cancel
Showing results for 
Search instead for 
Did you mean: 

html header image logo not showing - technical error

SOLVED

html header image logo not showing - technical error

New install of Magento 2.3

I want to add the logo image.

when clicking on upload and selecting a image (I used this image on my previous magento installation so correct image format. When done nothing shows. Normally the image is shown in a smal window. On front end also no image

 

I also get this error on top of the page in red

 

X   A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later. 

Schermafdruk 2018-12-06 15.13.31.png

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: html header image logo not showing - technical error

after looking arround and lots of frustration.

I seems like a bug in 2.3.

This wil be fixed in 2.3.1 see: https://github.com/magento/magento2/issues/18688

 

 

 

View solution in original post

Re: html header image logo not showing - technical error

solution:

edit file /vendor/magento/module-theme/view/adminhtml/ui_component/design_config_form.xml

 

change "fileUploader" to "imageUploader"

<collapsible>true</collapsible>
                <label translate="true">HTML Head</label>
            </settings>

            <field name="head_shortcut_icon" formElement="fileUploader">
change to:
            <field name="head_shortcut_icon" formElement="imageUploader">

                <settings>
                    <notice translate="true">Not all browsers support all these formats!</notice>
                    <label translate="true">Favicon Icon</label>
@@ -151,7 +151,7 @@
                <collapsible>true</collapsible>
                <label translate="true">Header</label>
            </settings>


            <field name="header_logo_src" formElement="fileUploader">
change to:
            <field name="header_logo_src" formElement="imageUploader">


                <settings>
                    <label translate="true">Logo Image</label>
                    <componentType>imageUploader</componentType>

then remove static-content

and deploy static content again.

 

This works for me on magento 2.3

View solution in original post

7 REPLIES 7

Re: html header image logo not showing - technical error

Hi,

Ensure that all admin users had privileges assigned to them via System > Permissions > User Roles

 

Refer : https://github.com/magento/magento2/issues/10071

 

Thanks!!

Re: html header image logo not showing - technical error

user is administrator

user roles: all

I also tryed custom and selected all fields

 

nothing changed

Re: html header image logo not showing - technical error

after looking arround and lots of frustration.

I seems like a bug in 2.3.

This wil be fixed in 2.3.1 see: https://github.com/magento/magento2/issues/18688

 

 

 

View solution in original post

Re: html header image logo not showing - technical error

solution:

edit file /vendor/magento/module-theme/view/adminhtml/ui_component/design_config_form.xml

 

change "fileUploader" to "imageUploader"

<collapsible>true</collapsible>
                <label translate="true">HTML Head</label>
            </settings>

            <field name="head_shortcut_icon" formElement="fileUploader">
change to:
            <field name="head_shortcut_icon" formElement="imageUploader">

                <settings>
                    <notice translate="true">Not all browsers support all these formats!</notice>
                    <label translate="true">Favicon Icon</label>
@@ -151,7 +151,7 @@
                <collapsible>true</collapsible>
                <label translate="true">Header</label>
            </settings>


            <field name="header_logo_src" formElement="fileUploader">
change to:
            <field name="header_logo_src" formElement="imageUploader">


                <settings>
                    <label translate="true">Logo Image</label>
                    <componentType>imageUploader</componentType>

then remove static-content

and deploy static content again.

 

This works for me on magento 2.3

View solution in original post

Re: html header image logo not showing - technical error

Did changing "fileUploader" to "imageUploader" really work for you?

I did that exact same thing but i still get the same error

and i am still unable to upload a logo 

 

 

 

----------update------------------

wait nevermind 

i refreshed the page and it work !!

youre a Gangsta !!
Thank you 

Re: html header image logo not showing - technical error

pls help i have similar problem

Re: html header image logo not showing - technical error

1.check your error by firebug
2.check your error on var/log if can't see error on step 1
3. check data post to server when adding product to cart if can't see error on step 2 (make sure data post to server when adding new product is enought)

 

 

Showbox on Windows 10 PC