cancel
Showing results for 
Search instead for 
Did you mean: 

2.3.4 TO 2.3.5-P1 via Composer

Highlighted

2.3.4 TO 2.3.5-P1 via Composer

I am currently trying to upgrade from 2.3.4 to 2.3.5-p1 using composer on XAMPP localhost. Following all the steps and completing I am still showing 2.3.4. For some reason it will not upgrade. As for as I can tell there are no errors. I was wondering in the command line should I be entering 2.3.5 instead of 2.3.5-p1
The command are as follows:

composer require magento/product-community-edition=2.3.5-p1 --no-update

I have attempted this twice and both has the same issue.

The only step I did have an issue with and not sure if it would be the problem is running the 

Clearing the var/AND generated/subdirectories. Each time I run it, it shows 'rm" is not recognized as an internal or external command, operable program or batch file

rm -rf var/cache/*

rm -rf var/page_cache/*

rm -rf generated/code/*

 

 

5 REPLIES 5
Highlighted

Re: 2.3.4 TO 2.3.5-P1 via Composer

Hello @Media Bug ,

 

rm command is used to remove objects such as files, directories, symbolic links and so on from the file system like UNIX, I assume that you are using Windows operating system so it is not recognising this command

NOTE :Use del on Windows or manually remove content from (var/cache/ , var/page_cache , generated/code/) .

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !
Highlighted

Re: 2.3.4 TO 2.3.5-P1 via Composer

Hi @Media Bug ,

 

Try del /? for something similar in windows, as windows doesn't know rm.

rd /? might also be worth to have a look at.

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

Highlighted

Re: 2.3.4 TO 2.3.5-P1 via Composer

Site updated to 2.3.5-p1 successfully. Had more errors than first thought. Issue was related to an outdated composer (1.6), upgraded to 1.10.9 and worked like a charm.  

Highlighted

Re: 2.3.4 TO 2.3.5-P1 via Composer

In the wake of fixing the executive can a seller still distantly deal with the framework if necessary? Does 4site keep on working typically?

Highlighted

Re: 2.3.4 TO 2.3.5-P1 via Composer

You forget the following command:

composer update