cancel
Showing results for 
Search instead for 
Did you mean: 

2.3.5p2 to 2.4.0 getting an pelago/emogrifier issue

SOLVED
Highlighted

2.3.5p2 to 2.4.0 getting an pelago/emogrifier issue

run : composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- magento/product-enterprise-edition 2.4.0 requires pelago/emogrifier ^3.1.0 -> satisfiable by pelago/emogrifier[3.1.x-dev, v3.1.0] but these conflict with your requirements or minimum-stability.
- magento/product-enterprise-edition 2.4.0 requires pelago/emogrifier ^3.1.0 -> satisfiable by pelago/emogrifier[3.1.x-dev, v3.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for magento/product-enterprise-edition 2.4.0 -> satisfiable by magento/product-enterprise-edition[2.4.0].

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: 2.3.5p2 to 2.4.0 getting an pelago/emogrifier issue

@karuna_khatri 

 

Just update pelago/emogrifier version in composer file to ^3.1.0 and run compose update command. Then Just try to upgrade Magento version. Give a try and let me know.

Manish Mittal
https://www.manishmittal.com/

View solution in original post

3 REPLIES 3
Highlighted

Re: 2.3.5p2 to 2.4.0 getting an pelago/emogrifier issue

@karuna_khatri 

 

Just update pelago/emogrifier version in composer file to ^3.1.0 and run compose update command. Then Just try to upgrade Magento version. Give a try and let me know.

Manish Mittal
https://www.manishmittal.com/

View solution in original post

Highlighted

Re: 2.3.5p2 to 2.4.0 getting an pelago/emogrifier issue

 

Thank you, @Manish Mittal 

it's working now.

Highlighted

Re: 2.3.5p2 to 2.4.0 getting an pelago/emogrifier issue

Great! cheers

Manish Mittal
https://www.manishmittal.com/