cancel
Showing results for 
Search instead for 
Did you mean: 

Can't upgrade to 2.3.4 from 2.4.2-p1 (Composer errors)

Can't upgrade to 2.3.4 from 2.4.2-p1 (Composer errors)

Tried to update using composer, but this time I've hit a lot of walls. I've cleared several of them and I think I'm down to this last one.

When I ran the composer update (with or without the -W give the same error)

I get this;

Loading composer repositories with package information
In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - composer/composer[1.9.0, ..., 1.10.x-dev] require composer/xdebug-handler ^1.1 -> found composer/xdebug-handler[1.1.0, ..., 1.4.x-dev] but it conflicts with your root composer.json require (2.0.2).
    - magento/product-community-edition 2.4.3 requires magento/composer 1.6.0 -> satisfiable by magento/composer[1.6.0].
    - magento/composer 1.6.0 requires composer/composer ^1.9 -> satisfiable by composer/composer[1.9.0, ..., 1.10.x-dev].
    - Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Even using the suggested -W doesn't work.

I tried to change the composer.json version number for the xdebug down to 1.4.x-dev in an attempt to alleviate the issue, but I end up getting the error below, which feels even worse!

 

 

If I alter the composer.json file and change the xdebug version to the lower number I get;

 

Loading composer repositories with package information
In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install friendsofphp/php-cs-fixer v3.0.0-beta.2 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.21 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.22 (conflict analysis result)
    - magento/product-community-edition 2.4.3 requires magento/composer 1.6.0 -> satisfiable by magento/composer[1.6.0].
    - friendsofphp/php-cs-fixer[v3.0.0-rc.1, ..., 3.0.x-dev] require composer/xdebug-handler ^2.0 -> found composer/xdebug-handler[2.0.0, 2.0.1, 2.0.2] but it conflicts with your root composer.json require (1.4.x-dev).
    - Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].
    - Conclusion: don't install composer/semver[1.5.1] | install one of composer/semver[3.2.1, 3.2.2, 3.2.3, 3.2.4] (conflict analysis result)
    - Conclusion: don't install composer/semver[3.2.1] | install one of composer/semver[1.5.2, 1.6.0, 1.7.0, 1.7.1] (conflict analysis result)
    - Conclusion: don't install composer/semver[1.5.2] | install one of composer/semver[3.2.2, 3.2.3, 3.2.4] (conflict analysis result)
    - Conclusion: don't install composer/semver[3.2.2] | install one of composer/semver[1.6.0, 1.7.0, 1.7.1] (conflict analysis result)
    - Conclusion: don't install composer/semver[1.6.0] | install one of composer/semver[3.2.3, 3.2.4] (conflict analysis result)
    - Conclusion: don't install composer/semver[3.2.3] | install one of composer/semver[1.7.0, 1.7.1] (conflict analysis result)
    - Conclusion: don't install composer/semver[1.7.0] | install composer/semver[3.2.4] (conflict analysis result)
    - Conclusion: don't install composer/semver 3.2.4 (conflict analysis result)
    - Conclusion: don't install composer/semver 1.7.1 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.0-RC (conflict analysis result)
    - Conclusion: don't install composer/composer 1.9.3 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.0 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.1 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.2 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.3 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.4 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.5 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.6 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.7 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.8 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.9 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.10 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.11 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.12 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.13 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.14 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.15 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.16 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.17 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.18 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.19 (conflict analysis result)
    - Conclusion: don't install composer/composer 1.10.20 (conflict analysis result)
    - Conclusion: don't install one of composer/semver[1.7.2], friendsofphp/php-cs-fixer[v3.0.0-beta.1] | install composer/semver[3.2.5] (conflict analysis result)
    - Conclusion: don't install composer/semver 3.2.5 (conflict analysis result)
    - Root composer.json requires friendsofphp/php-cs-fixer ^3.0 -> satisfiable by friendsofphp/php-cs-fixer[v3.0.0-beta.1, ..., 3.0.x-dev].
    - magento/composer 1.6.0 requires composer/composer ^1.9 -> satisfiable by composer/composer[1.9.0, ..., 1.10.x-dev].
    - composer/composer[1.9.0, ..., 1.10.x-dev] require composer/semver ^1.0 -> satisfiable by composer/semver[1.0.0, ..., 1.x-dev].
    - You can only install one version of a package, so only one of these can be installed: composer/semver[dev-main, 1.0.0, ..., 1.x-dev, 2.0.0, 3.0.0, ..., 3.2.5].
    - composer/semver 3.x-dev is an alias of composer/semver dev-main and thus requires it to be installed too.
    - friendsofphp/php-cs-fixer v3.0.0-beta.1 requires composer/semver ^3.2 -> satisfiable by composer/semver[3.2.0, ..., 3.x-dev (alias of dev-main)].
    - Conclusion: don't install composer/semver[3.2.0] | install one of composer/semver[1.5.1, ..., 1.7.1] (conflict analysis result)

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

 

Any suggestions for what I might try?

4 REPLIES 4

Re: Can't upgrade to 2.3.4 from 2.4.2-p1 (Composer errors)

Hello @lexifir,

 

Hope you are doing well!

 

There are many errors faced by developers while upgrading to newer version in Magento. Basically there are some by default bugs from Magento itself but many times manual mistakes are faced while installation. For your issue I suggest to review this sources which helped me solvong my errors while upgrading to new version in Magento.

 

Reference link: https://github.com/magento/magento2/issues/23405

 

Incase if it is not solved then follow this process https://meetanshi.com/blog/upgrade-magento-to-latest-version/

 

Hope this helps. Hit the kudos button and accept as solution if it helped you.

 

Thank-You

 

 

 

Re: Can't upgrade to 2.3.4 from 2.4.2-p1 (Composer errors)

Neither of those two pages has content relevant to this issue - but thanks for trying.

Re: Can't upgrade to 2.3.4 from 2.4.2-p1 (Composer errors)

Same problem here. Upgrade to 2.4.3 is a dependency mess. It keeps complaining about composer 1.9 conflicts even though composer 1.9 is referenced nowhere that I can see.

 

Another premature Magento release I guess. I'll go back to 2.4.2p2 and follow this post for updates. Smiley Happy

Re: Can't upgrade to 2.3.4 from 2.4.2-p1 (Composer errors)

I have face same issue from couple of days anyone know about this so please reply. Thanks in advance.

 

mcdvoice