cancel
Showing results for 
Search instead for 
Did you mean: 

Compilation error after upgrading to version 2.3.3

Highlighted

Compilation error after upgrading to version 2.3.3

Hi guys. after upgrading our site to version 2.3.3 in static deploy on the live server i got the following errors:

Compilation from source /home/www-mz/htdocs/app/design/frontend/nine/mc/web/css/jquery.dmenu.css failed
Magento\Framework\View\Asset\File\NotFoundException: Unable to resolve the source file for 'frontend/nine/mc/nb_NO/css/jquery.dmenu.css' in /home/www-mz/htdocs/vendor/magento/framework/View/Asset/File.php:160
9 REPLIES 9
Highlighted

Re: Compilation error after upgrading to version 2.3.3

Hello @5d19c60a6d1cc 

Did you try compilation with the default theme? 
There are chances some of the components of your current installed theme is not fully compatible with Magento 2.3.3 and hence compilation is showing an error to you.

 

You can also ask theme vendor for this issue if they have patch ready for Magento 2.3.3

Found something useful, "Kudos" and "Accept as Solution" for Token of Appreciation.

Magento Tutorials
Highlighted

Re: Compilation error after upgrading to version 2.3.3

Hi @5d19c60a6d1cc 

 

You can use the below command to disable the compilation.

After that run the static content deploy command and if everything works fine in the end enable to compilation by using enable instead of disable in command.

 

php -f shell/compiler.php -- disable

Thanks!

Highlighted

Re: Compilation error after upgrading to version 2.3.3

Hi. the theme i use is made by me.

Highlighted

Re: Compilation error after upgrading to version 2.3.3

Hi @5d19c60a6d1cc 

 

Have you tried my solution?

 

Thanks!

Highlighted

Re: Compilation error after upgrading to version 2.3.3

yes, error still occuring


@Rahul Gupta wrote:

Hi @5d19c60a6d1cc 

 

Have you tried my solution?

 

Thanks!


 

Highlighted

Re: Compilation error after upgrading to version 2.3.3

Hi @5d19c60a6d1cc 

 

After disabling compilation have you flush the cache?

 

Highlighted

Re: Compilation error after upgrading to version 2.3.3


@Rahul Gupta wrote:

Hi @5d19c60a6d1cc 

 

After disabling compilation have you flush the cache?

 


yes, i will also update my question. because right now the error is also now occurring in my local machine.

Re: Compilation error after upgrading to version 2.3.3

Hi @5d19c60a6d1cc 

 

Please run the following commands in the below sequence.

 

php bin/magento cache:flush
sudo chmod -R 777 var/ pub/static/ generated/
rm -rf var/generation/* var/cache/* var/report/* pub/static/frontend/* var/page_cache/* generated/*
php bin/magento setup:upgrade
sudo chmod -R 777 var/ pub/static/ generated/
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush

Thanks!

Highlighted

Re: Compilation error after upgrading to version 2.3.3

Hello @5d19c60a6d1cc 

 

This issue due to theme directory or theme vendor name is renamed. Try below step to fix this.

  1. Change your theme vendor first letter in capitol. Your vendor name is "nine" make it "Nine"
  2. Change the theme directory name into theme's.
    app\design\frontend\<Nine>\<mc>\composer.json
    app\design\frontend\<Nine>\<mc>\theme.xml  (if parent theme is not default magento)
    app\design\frontend\<Nine>\<mc>\registration.php
  3. Now, delete your current theme entry from the "theme" table, but keep back-up of this table before removing custom theme entry
  4. Now run the command for setup-upgrade, static content deploy, and cache clear.
  5. rm -rf var/di/* var/generation/* var/cache/* var/log/* var/page_cache/* var/session/* var/view_preprocessed/*
    
    php bin/magento setup:upgrade
    php bin/magento setup:static-content:deploy -f
    php bin/magento c:f && php bin/magento c:c
  6. Now you will not see the compilation error
  7. Now you will see new entry into the "theme" database table
  8. Change your store theme from admin

Thank you