cancel
Showing results for 
Search instead for 
Did you mean: 

Compile error after upgrade 2.3.1 -> 2.3.3 | Magento deprecated files removal

SOLVED
Highlighted

Compile error after upgrade 2.3.1 -> 2.3.3 | Magento deprecated files removal

We just updated our test site from 2.3.1 to 2.3.3 and we are facing the same exact issue as in this discussion: https://magento.stackexchange.com/questions/291667/magento-2-3-2-error-while-compilation

In short, the compilation stops after 1/7 and the error log shows the same message as in the Stackexchange discussion. The compiler works normally if I rename/remove the file /vendor/magento/module-quote-graph-ql/Model/Cart/SetShippingAddressOnCart.php, but is this file deprecated and not needed anymore from 2.3.3 onwards?

And what about the rest of the files listed by G.G. in the same topic, are they also useless in the versions 2.3.3 and newer?

 

If they are deprecated, is there any programmatical way to find and delete all the old/deprecated files left behind by newer versions of Magento?

 

This Magento has been originally installed with Installatron and it's kept up-to-date with it also.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Compile error after upgrade 2.3.1 -> 2.3.3 | Magento deprecated files removal

Hello @finbayern 

 

You can delete vendor files and folder and run below commands:

 

php bin/magento maintenance:enable
rm -rf vendor/
composer install
composer require magento/product-community-edition=2.3.3 --no-update
composer update
rm -rf var/cache/* var/page_cache/* var/generation/*
rm -rf var/di var/page_cache/ var/generation/ var/cache/*
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:flush

Please take back-up vendor folder before deleting any files and folder. 

Manish Mittal
https://www.manishmittal.com/

View solution in original post

1 REPLY 1
Highlighted

Re: Compile error after upgrade 2.3.1 -> 2.3.3 | Magento deprecated files removal

Hello @finbayern 

 

You can delete vendor files and folder and run below commands:

 

php bin/magento maintenance:enable
rm -rf vendor/
composer install
composer require magento/product-community-edition=2.3.3 --no-update
composer update
rm -rf var/cache/* var/page_cache/* var/generation/*
rm -rf var/di var/page_cache/ var/generation/ var/cache/*
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:flush

Please take back-up vendor folder before deleting any files and folder. 

Manish Mittal
https://www.manishmittal.com/

View solution in original post