cancel
Showing results for 
Search instead for 
Did you mean: 

Error during Upgrade from 2.3.3 to 2.3.5

SOLVED
Highlighted

Error during Upgrade from 2.3.3 to 2.3.5

I started upgrading from version 2.3.3 to 2.3.5, but Magento crashed during the Composer update with the following error:

PHP Version 7.2.x on Ubuntu 18.04

- Installing laminas/laminas-dependency-plugin (1.0.3): Downloading (100%)
PHP Fatal error: Uncaught Error: Undefined class constant 'PRE_COMMAND_RUN' in /var/www/html/erag.swiss/public_html/vendor/laminas/laminas-dependency-plugin/src/DependencyRewriterPlugin.php:63
Stack trace:
#0 phar:///usr/local/bin/composer/src/Composer/EventDispatcher/EventDispatcher.php(378): Laminas\DependencyPlugin\DependencyRewriterPlugin::getSubscribedEvents()
#1 phar:///usr/local/bin/composer/src/Composer/Plugin/PluginManager.php(239): Composer\EventDispatcher\EventDispatcher->addSubscriber(Object(Laminas\DependencyPlugin\DependencyRewriterPlugin))
#2 phar:///usr/local/bin/composer/src/Composer/Plugin/PluginManager.php(205): Composer\Plugin\PluginManager->addPlugin(Object(Laminas\DependencyPlugin\DependencyRewriterPlugin))
#3 phar:///usr/local/bin/composer/src/Composer/Installer/PluginInstaller.php(63): Composer\Plugin\PluginManager->registerPackage(Object(Composer\Package\CompletePackage), true)
#4 phar:///usr/local/bin/composer/src/Composer/Installer/InstallationManager.php(173): Composer\Installer\PluginInstaller->in in /var/www/html/erag.swiss/public_html/vendor/laminas/laminas-dependency-plugin/src/DependencyRewriterPlugin.php on line 63

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Error during Upgrade from 2.3.3 to 2.3.5

Hello @ERAG 

 

I understand the problem you are facing !

 

Yesterday i i did try the same and facing the same error.

 

Solution is you will require to update your composer first !

 

Currently your composer might have version 1.6.5 or upper, So first update your composer version by running following command from the root user.

composer self-update

 It will update composer to latest version which is 1.10.5 something.

 

Once that is done - Run your commands again to update the Magento version, it will not gives you the error and it will works for you.

 

Hope it helps !

if issue solved,Click Kudos & Accept as Solution

View solution in original post

1 REPLY 1
Highlighted

Re: Error during Upgrade from 2.3.3 to 2.3.5

Hello @ERAG 

 

I understand the problem you are facing !

 

Yesterday i i did try the same and facing the same error.

 

Solution is you will require to update your composer first !

 

Currently your composer might have version 1.6.5 or upper, So first update your composer version by running following command from the root user.

composer self-update

 It will update composer to latest version which is 1.10.5 something.

 

Once that is done - Run your commands again to update the Magento version, it will not gives you the error and it will works for you.

 

Hope it helps !

if issue solved,Click Kudos & Accept as Solution

View solution in original post