cancel
Showing results for 
Search instead for 
Did you mean: 

Error on magento 2 version upgrade magento 2.3.1 to 2.3.5p2

SOLVED

Error on magento 2 version upgrade magento 2.3.1 to 2.3.5p2

I am getting error when I am  running composer update on upgrading magento version 2.3.1 to 2.3.5p2

 

ERROR:

Problem 1 - magento/magento-cloud-metapackage 2.3.1 requires magento/product-enterprise-edition 2.3.1 -> satisfiable by magento/product-enterprise-edition[2.3.1] but these conflict with your requirements or minimum-stability. - magento/magento-cloud-metapackage 2.3.1-p1 requires magento/product-enterprise-edition 2.3.1 -> satisfiable by magento/product-enterprise-edition[2.3.1] but these conflict with your requirements or minimum-stability. - magento/magento-cloud-metapackage 2.3.1-p1 requires magento/product-enterprise-edition 2.3.1 -> satisfiable by magento/product-enterprise-edition[2.3.1] but these conflict with your requirements or minimum-stability. - Installation request for magento/magento-cloud-metapackage >=2.3.1 <2.3.2 -> satisfiable by magento/magento-cloud-metapackage[2.3.1-p1, 2.3.1].

 

How can I fix this issue

Please suggest.



1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error on magento 2 version upgrade magento 2.3.1 to 2.3.5p2

Hi @krishenuetb254 

 

Please make sure the version in the compser.json file. It should be updated version 2.3.5. If not then update version 2.3.5  and I am assuming it is cloud magento version then update  magento-cloud-metapackage version on composer.json file as per mentioned below: 


Then run composer update

 

"version": "2.3.5"

 

and update meta-package version lower to higher version

 

 

"require": {

"magento/magento-cloud-metapackage": ">=2.3.5 <2.3.6"

}

 

Hope this helps you!
Problem Solved! Click Kudos & Accept as Solution!

View solution in original post

2 REPLIES 2

Re: Error on magento 2 version upgrade magento 2.3.1 to 2.3.5p2

Hi @krishenuetb254 

 

Please make sure the version in the compser.json file. It should be updated version 2.3.5. If not then update version 2.3.5  and I am assuming it is cloud magento version then update  magento-cloud-metapackage version on composer.json file as per mentioned below: 


Then run composer update

 

"version": "2.3.5"

 

and update meta-package version lower to higher version

 

 

"require": {

"magento/magento-cloud-metapackage": ">=2.3.5 <2.3.6"

}

 

Hope this helps you!
Problem Solved! Click Kudos & Accept as Solution!

View solution in original post

Re: Error on magento 2 version upgrade magento 2.3.1 to 2.3.5p2

Thanks @Madhu Rajawat 

Fixed the error.