cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade Magento 2.3.5-p2 to 2.4

SOLVED
Highlighted

Upgrade Magento 2.3.5-p2 to 2.4

Hi, I encounter problem when upgrade from M2 2.3.5-p2 to 2.4.

 

I do the following before update.

 

 

 

composer require magento/composer-root-update-plugin=~1.0 --no-update
composer update

 

 

[magento_usr@store-magento m23]$ composer require magento/product-community-edition=2.4.0 --interactive-magento-conflicts --no-update
Magento Open Source 2.4.0 is trying to change the existing order of the require section.
Local order:
   [
      magento/composer-root-update-plugin,
      magento/product-community-edition
   ]
Magento Open Source 2.4.0 order:
   [
      magento/product-community-edition,
      magento/composer-root-update-plugin
   ]
Would you like to override the local order? [y,N]? y
Magento Open Source 2.4.0 is trying to update require-dev:magento/magento2-functional-testing-framework to ^3.0 from ~2.6.4 in Magento Open Source 2.3.5-p2 but it is instead 2.4.5 in this installation.
Would you like to override the local changes? [y,N]? y
Magento Open Source 2.4.0 is trying to update require-dev:phpstan/phpstan to >=0.12.3 <=0.12.23 from ^0.12.2 in Magento Open Source 2.3.5-p2 but the field has been removed in this installation.
Would you like to override the local changes? [y,N]? y
Updating composer.json for Magento Open Source 2.4.0 ...
./composer.json has been updated

 

Then the composer complain ElasticSearch not satisfy the requirement. But I'm using 7.9 instead.

 

[magento_usr@store-magento m23]$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].
    - magento/product-community-edition 2.4.0 requires elasticsearch/elasticsearch ~7.7.0 -> satisfiable by elasticsearch/elasticsearch[7.7.x-dev, v7.7.0] but these conflict with your requirements or minimum-stability.

 

Please let me know if you have any comment or hint. Thank you.

 

 

 

--------------------

I'm on CentOS7 with the following technology stack installed.

php.x86_64                               7.3.22-1.el7.remi           @remi-php73

mysql-community-server.x86_64            5.7.31-1.el7                @mysql57-community

elasticsearch.x86_64                     7.9.1-1                     @elasticsearch

 

Composer

magento/product-community-edition                                 2.3.5-p2 

elasticsearch/elasticsearch                                       v7.9.0    

magento/module-elasticsearch                                      100.3.5   

magento/module-elasticsearch-6                                    100.3.4   

magento/module-elasticsearch-7                                    100.3.0   

magento/module-inventory-elasticsearch                            1.0.3 

 

Regards,

kf

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Upgrade Magento 2.3.5-p2 to 2.4

After investigate it was caused by mailchimp (mailchimp/mc-magento2) extension incompatible with 2.4.

View solution in original post

1 REPLY 1
Highlighted

Re: Upgrade Magento 2.3.5-p2 to 2.4

After investigate it was caused by mailchimp (mailchimp/mc-magento2) extension incompatible with 2.4.

View solution in original post