cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade to 2.4.4 PHP 8.1 error

Upgrade to 2.4.4 PHP 8.1 error

Hi,

I am currently upgrading our instance of Adobe Commerce from 2.4.2 to 2.4.4. I ran all the instructed steps from this documentation during my upgrade process (https://devdocs.magento.com/cloud/project/project-upgrade.html). I reached the part of the instructions to push my local changes to the remote server (currently on Magento Cloud). Upon doing so, the deployment stopped with multiple errors. All of them were of the same type of error:

 
    W:   Problem 15
    W:     - magento/framework is locked to version 103.0.4-beta1 and an update of this package was not requested.
    W:     - magento/framework 103.0.4-beta1 requires php ~7.3.0||~7.4.0 -> your php version (8.1.6RC1) does not satisfy that requirement.

 

I've seen this error on other posts but could not find a solution for it.

 

Please advise.