cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading to 2.0.1 stuck

Highlighted

Re: Upgrading to 2.0.1 stuck

You can use

bin/magento maintenance:disable 

to lift maintenance mode so that you can proceed with rollback

Highlighted

Re: Upgrading to 2.0.1 stuck

update_status.log contained the same information displayed in the original post. 

 

3 things:

 

1. I had to re-enable maintenance mode

2. I was not able to do a magento setup:rollback on the DB portion. It failed on every attempt. I was however able to take the .gz file that was generated and restore the data via phpmyadmin.

3. I waited more than 30 mins. Even tried to clear the var/cache folder to see if that helped, it didn't. 

 

Now everytime I go back into "Web Setup Wizard" it takes me directly to the "New Purchases" page with the status still saying "Update application is running"

 

Site's still up though and everything is functioning normal except for that.

Highlighted

Re: Upgrading to 2.0.1 stuck


@maddyC wrote:

Once composer.json is updated, it takes a while, sometimes 5-7 minutes. Please check you var folder and check contents of 

update_status.log

It should give you an idea of what exactly is wrong. 


@maddyC I'm having exact same problem as @tfransen Contents of update_status.log are also exact same. Not sure that I want to put my site back live since Magento just published a bunch of security vulnerabilities without a mechanism to patch. How to proceed?

Highlighted

Re: Upgrading to 2.0.1 stuck

Having same issue.

Highlighted

Re: Upgrading to 2.0.1 stuck

I was stuck in the same exact place.  I ran the maintenance:disable command and I can access my site.  The magento version in my admin panel is still 2.0.  The site appears to be functioning.  Didn't use rollback.

Highlighted

Re: Upgrading to 2.0.1 stuck

Check this out I had the same problem so i resorted to CLI and problem solved.
Magento CE 2.0.0 upgrade to Magento CE 2.0.1 Fails to update with no errors

Highlighted

Re: Upgrading to 2.0.1 stuck

I tried to update via those instructions and now my site isn't functioning at all.  Now I'm getting a bunch of uncaught PHP errors.

 

 PHP Fatal error:  Uncaught exception 'Magento\\Framework\\Exception\\LocalizedException' with message 'Can't create directory /var/www/html/magento_test/jedwards/var/generation/Magento/Framework/App/ResourceConnection/.' in /var/www/html/magento_test/jedwards/vendor/magento/framework/Code/Generator.php:103\nStack trace:\n#0...

 

All I did was attempt to update the website via the GUI in admin and now nothing works.  Very poor release by the Magento team IMHO.

 

This update was so bad that I am seriously considering not implementing Magento 2.  Doesn't seem ready for production.

 

Highlighted

Re: Upgrading to 2.0.1 stuck

I attempted to do the CLI and unfortunately only got as far as step 2, due to the fact that the following line was NOT in my composer.json file.

Find line change 2.0.0 to 2.0.1 Example below
"require": {
    "magento/product-community-edition": "2.0.1",
Highlighted

Re: Upgrading to 2.0.1 stuck

The docs say to use the system upgrade utility if you used composer, which I did.  I tried this and my install hangs forever on " ./composer.json has been updated".

The upgrade docs don't currently comment on using the command line to upgrade (http://devdocs.magento.com/guides/v2.0/comp-mgr/bk-compman-upgrade-guide.html ) so I tried that from the install guide (http://devdocs.magento.com/guides/v2.0/install-gde/install/cli/install-cli-subcommands.html ).
    
 Switch to the magento file system owner.  In my case that's " magento_user".
    
        cd to <your_install>/bin
        su magento_user
        
        ./magento maintenance:enable
        
        # ran with sudo
        composer self-update
        # cd to directory with composer.json
        composer update
        
        # to fix my broken file permssions
        sudo chown -hR magento_user:www-data /var/www/html/<your_install>
        # set magento to be executible
        sudo chmod u+x magento
        
        ./magento setup:upgrade
        ./magento cache:flush
        ./magento maintenance:disable
        
The footer of the admin page says I'm on version 2.0.1 but when I go to the web set up wizard it still displays the same page and is stuck on "./composer.json has been updated".

 

My current issue is I think I've updated to 2.01 via terminal but the web setup wizard is still frozen.

 

Anybody know how to fix this?

 

https://drive.google.com/file/d/0Bz-w7AN9Bim5RmhzRTYzVXVTNFk/view?usp=sharing

 

 

Highlighted

Re: Upgrading to 2.0.1 stuck

CCshane, system => web set up wizard is fixed on your install?

 

FWIW I've opened a ticket to fix the wizard.  https://github.com/magento/magento2/issues/3166