cancel
Showing results for 
Search instead for 
Did you mean: 

upgrade from 1.9 to 2.X troubles

Highlighted

upgrade from 1.9 to 2.X troubles

I'm pretty good with linux and github but this is very confusing.  I have a few ways to do the upgrade and none of them work.  Please help!!!  bluehost said they are dropping php 5.X and I need to get onto PHP 7.X

 

Method 1: No composer.  Bluehost has this softaculous control panel that installed magento 2.3.6 perfectly and it works but now I need migration tool and all documentation I can find (all of it!) requires composer to work.  Is there a way without composer?

 

Method 2: Composer.  I can't get it to work.  Bluehost has this installed already in /opt/cpanel/composer/bin/composer so when I type "composer" it runs that.  But it is version 1.8.6 and it doesn't seem to work well with installing magento 2.  Every time it crashes after blowing memory while looking at dependencies.  So I installed composer.phar in my home folder but that gets all kinds of errors as well (at least it doesn't crash):

 

 [~/public_html/stor]# ../composer.phar require magento/data-migration-tool:2.3.5
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "laminas/laminas-dependency-plugin" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/composer-root-update-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
./composer.json has been updated
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "laminas/laminas-dependency-plugin" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/composer-root-update-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Running composer update magento/data-migration-tool
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/composer-root-update-plugin is locked to version 1.0.0 and an update of this package was not requested.
    - magento/composer-root-update-plugin 1.0.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
  Problem 2
    - dealerdirect/phpcodesniffer-composer-installer is locked to version v0.5.0 and an update of this package was not requested.
    - dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
  Problem 3
    - laminas/laminas-dependency-plugin 1.0.4 requires composer-plugin-api ^1.1 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
    - magento/product-community-edition 2.3.6 requires laminas/laminas-dependency-plugin ^1.0 -> satisfiable by laminas/laminas-dependency-plugin[1.0.4].
    - magento/product-community-edition is locked to version 2.3.6 and an update of this package was not requested.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

 I'm not sure if softaculous created composer.json and composer.lock files or not.  I suspect not.  I could completely delete the install and database and do it all over again I suppose and see if those files are there.  But I think those 2 files got created by composer 1.X.  So I renamed them and tried again but still no luck.

 

I'd prefer method1 in case I ever need to use composer again some day as 90% of the help on the internet seems to involve using composer.

 

Oh - and problem #3 is that there seems to be no migration tool for magento 2.3.6 and 2.2.11 (just 2.3.5 and 2.2.10).  What's up with that?  And softaculous only lets me install these 2 versions of Magento.  So I'm hoping migration tool version 2.3.5 works for magento 2.3.6.  If not then my method #2 is not an option.

2 REPLIES 2
Highlighted

Re: upgrade from 1.9 to 2.X troubles

help?  please?

Highlighted

Re: upgrade from 1.9 to 2.X troubles

bump?  I spent an hour on this again last night.  No luck.