Showing results for 
Search instead for 
Did you mean: 

'Save & apply' function not working

'Save & apply' function not working

Hi all,


I'm trying to create a catalog rule in magento but when I hit the save & apply button it will load for 10 minutes and show an error page.  We have upgraded our memory for the site but this has not solved the problem.  Any help would be appreciated.




Re: 'Save & apply' function not working

Hmm, do you have any custom extensions installed that affect this area? Does the same thing happen if you hit save without applying?


The error shown is a 500 which suggests error rather than timeout. I'm not sure why it would take so long. Is it a complex rule or one that applies to many products?

If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: 'Save & apply' function not working

The rule is very basic.  I am trying to apply a percentage discount to a few skus.  I am using magento version   I am still testing the prices using the 'save' button, but from what I see so far it the rule will be applied a day later.  This problem is a recent occurrence so I thought it was because of the number of rules that have been created taking up memory. I have deleted more than 100 unused rules and still no change.