cancel
Showing results for 
Search instead for 
Did you mean: 

PHP 7.4 doesnt work

Highlighted

PHP 7.4 doesnt work

Hello,

 

cannot launch Magento 2.3.3 on php 7.4.

It says:

Problem: magento/product-community-edition 2.3.3 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.4.0RC4) does not satisfy that requirement.

How can I run it on Php 7.4?

Thank you.

4 REPLIES 4

Re: PHP 7.4 doesnt work

Hello @iiru 

 

Magento 2 hasn't added support for php 7.4

Check  out Magento 2 release notes

Magento 2.3.3 now supports PHP 7.3.x (tested with PHP 7.3.8) and PHP 7.2.x (tested with 7.2.21).

https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-open-source.html

Found something useful, "Kudos" and "Accept as Solution" for Token of Appreciation.

Magento Tutorials
Highlighted

Re: PHP 7.4 doesnt work

Hi @iiru 

 

Currently php7.4 is not added in magento.

 

So you can just install php 7.3 in addition to php7.4 and set php7.3 as primary.

Then you will be able to run your magento.

 

Thanks

Highlighted

Re: PHP 7.4 doesnt work

Eu forcei a instalação alterando o arquivo composer.lock na linha 

"php": "~7.1.3||~7.2.0||~7.3.0||~7.4.1",
Highlighted

Re: PHP 7.4 doesnt work

Please follow the below to resolve this

 

For solution you can follow below links.
First you have to check your system which full-fill magento 2 system requirement.
https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html


Let me know if any issues


If my answer is useful, please Accept as Solution & give Kudos