Showing results for 
Search instead for 
Did you mean: 

Web server works until this line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SERVER)

Web server works until this line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SERVER)

I've been trying to pinpoint the exact point of failure with the installer setup utility. 

I've been able to get the index.php file to serve to the browser when I comment out the line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SERVER); and all lines following.

Attempting to leave this line uncommented leaves a 500 error on the browser and this error in the magento_error.log ...
proxy_fcgi:error] [pid 19212:tid 139802175330048] [client] AH01071: Got error 'Primary script unknown\n'


What I don't understand about the logic in the line causing the error.  I don't have any file path from the root of this computer that is at \Magento\Framework\App\Bootstrap.
I don't have any file path from the Magento folder on my web server.

Does this file attempt to create this space for writing or work space?  How can I set permissions for a file / folder path that does not exist and is created at run time?


Re: Web server works until this line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SER

Hello  @GrocExp 

Is it fresh Magento 2.3.3?
Did you ask hosting guys about this?

Is .htaccess file is proper?

And file permissions has proper permissions to run the Magento?

Was my answer helpful? You can accept it as a solution.
175+ Professional Extensions for M1 & M2
Need a developer?Just visit Contact Us Now

Re: Web server works until this line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SER

Thank you for being the one person to read and comment.

This is a clean install on CENTOS 8.  I've loaded all the software on this server myself.  There is a long list of items, if I can remember them all.  Firewall, apache, mysql, php, mysqladmin, GNOME, xrdp, text editior, etc...

I can get my <? PHP.Info file to work.  It shows all the information as expected.  On my original statement the page will load line by line until it trys to process $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SER

I tried getting Composer to run in terminal.  I was able to fix a few extension issues, but right now I'm stuck with Composer with this error ...

the requested PHP extension pdo_mysql is missing from your system.

If you want me to dump my screen to this chat, let me know.

Re: Web server works until this line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SER

I built this server myself.  It's not in a hosting environment.

I think the problem is I had mysql 8 installed.

I formatted the server and now I'm trying to re-build with CENTOS 8 and default MariaDB.

Re: Web server works until this line $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SER

I'm still working on getting to the Magento setup program to work in the browser.  I've been trying to make this happen for months now.
I ran some com-pliancy tests and figured out I can not run php 7.4.  I spent some time to get back to php 7.3.
I was also able to get the Magento error to screen print this is what I currently see ...

Fatal error: Uncaught ReflectionException: Class Magento\Framework\App\ResourceConnection\Proxy does not exist in /var/www/html/Magento/vendor/magento/framework/Code/Reader/ClassReader.php:19 Stack trace: #0 /var/www/html/Magento/vendor/magento/framework/Code/Reader/ClassReader.php(19): ReflectionClass->__construct('Magento\\Framewo...') #1 /var/www/html/Magento/vendor/magento/framework/ObjectManager/Definition/Runtime.php(49): Magento\Framework\Code\Reader\ClassReader->getConstructor('Magento\\Framewo...') #2 /var/www/html/Magento/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php(48): Magento\Framework\ObjectManager\Definition\Runtime->getParameters('Magento\\Framewo...') #3 /var/www/html/Magento/vendor/magento/framework/ObjectManager/ObjectManager.php(70): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\\Framewo...') #4 /var/www/html/Magento/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(160): Magento\Framework\ObjectManager\ObjectManager->get('Magento\\F in /var/www/html/Magento/vendor/magento/framework/Code/Reader/ClassReader.php on line 19