cancel
Showing results for 
Search instead for 
Did you mean: 

One page checkout stopped working for guests

Highlighted

One page checkout stopped working for guests

Hello.

I have a store on Magento CE 1.9.4 that's working from 2013.

Suddenly, I started having complains from customers that it required the code-words to be matched. Which code-words? No code-words have been entered.

Trying to replicate the problem, I realized that when someone was trying to complete the purchase as guest, when he clicked the "Continue" button after having entered the address details, he was getting the message "The code-words you have entered don't match". The process could not continue no matter what the user tried.

If someone chose to register, everything was OK. So I set the "Allow purchases from guests" to "No" and tried again. When I was at the address step, I saw two more fields that appeared: Password and Password confirmation. I set a password and confirmation and clicked the "Continue" button. The message "The code-words you have entered don't match" appeared again and the process stopped there.

Only when I set the option "Require Customer To Be Logged In To Checkout" to "Yes" I was able to complete the purchase.

This is a setting that discourage customers and I want it to work as previous (guest could complete the purchase without problems).

I suspected that the problem was caused from the migration tool, since its installation was my only intervention the last year or something.

Is there anyone who knows how to resolve this?

 

3 REPLIES 3
Highlighted

Re: One page checkout stopped working for guests

Hello @dkontod 

 

Are you using any captcha module if yes then disabled it and check it?

 

Mostly it is related to google captcha.

 

Hope it will help you.

 

Cheers Smiley Happy 

Highlighted

Re: One page checkout stopped working for guests

Hello Sunil.
As a matter of fact I was using a Google captcha. I disabled it as my first action. It didn't solve the problem.

Re: One page checkout stopped working for guests

No, it was the first I deleted