cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.9.3.9 doesn't include SUPEE-10570v2

Highlighted

Magento 1.9.3.9 doesn't include SUPEE-10570v2

Hello

After upgrading to magento 1.9.3.9, I realized that a problem fixed by patch SUPEE-10570v2 reappeared: when a logged in user adds a product to the cart, a blank page (500 error) is shown if the compilation is enabled.

Why does the last version of Magento not include SUPEE-10570v2? Is there any security reason for that? Is it safe to re-apply the patch on the top of 1.9.3.9?

Thank you in advance for the advice.

Maxime

 

 

12 REPLIES 12
Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Hi @maxime_tanuki,

 

I've made 2 upgrades and Ididn't get the error.

Maybe you can try to compare the code? (The OpenMage mirror on github could be useful for that job)

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Thank you for your reply.

 

I compared the code and SUPEE-10570v2 is indeed not included. Instead, SUPEE-10570 is included like specified on the download page.

It  is a bit annoying to reapply the patch on each new version (assuming it would work..). I was wondering why the last version of the patch is not used.

 

This issue is also discussed here (But not officially answered):

https://magento.stackexchange.com/questions/231579/security-patch-supee-10752-possible-issues

 

 

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Hi @maxime_tanuki,

 

You're absolutely right and this is being discussed on several places.

What I was able to understand (is not an official communication) it shouldn't be necessary to apply the V2 patch to Magento 1.9.3.9 but it's being checked currently.

 

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Hi @maxime_tanuki,

 

You can't use my answer as oficial (because is not) but the answer that I was able to find is you don't need to change anything on 1.9.3.9 (or 1.14.3.9) becuase both versiones include the proper fix for the issue that 10570v2 removed.

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Same issue here. Upgraded to 1.9.3.9 and getting a blank page when adding product to cart. Same as with 1.9.3.8 before SUPEE-10570v2. Any ideas on how to fix this issue?

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Hi @dbabaev,

 

Did you check this answer? https://magento.stackexchange.com/a/231614/6521

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

yes but it didn't help. I installed a fresh 1.9.3.9 and it's having that problem. I think they reverted SUPEE-10570v2 for some reason. Not sure how to resolve it but it's a major issue for new installations. Also, if you patch to SUPEE-10752 it reverts any SUPEE-10570v2 changes.

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

Hello. 1.9.3.9 includes a different solution to the problem that was partially solved in 10570 and then reverted in 10570v2. There is no need to install any patch over 1.9.3.9 as of now. 

Highlighted

Re: Magento 1.9.3.9 doesn't include SUPEE-10570v2

I have a fresh 1.9.3.9 install on a new database and I am experiencing this problem: when a logged in user adds a product to the cart, a blank page (500 error) is shown if the compilation is enabled.