cancel
Showing results for 
Search instead for 
Did you mean: 

reCAPTCHA is not supported

SOLVED

reCAPTCHA is not supported

Hello

 

We are using Magento ver. dev-2.4-develop

Our security scan recommends to allow google reCAPTCHA

But there is not any option in our admin panel to enable it.

 

As guide says we should have same options in admin panel to enable it but seems our magento does not supports google recaptcha at all.

How we can appear it?

 

Captdfgdfgure.PNG

 

Please help!

 

Cheers

1 ACCEPTED SOLUTION

Accepted Solutions

Re: reCAPTCHA is not supported

Finally I find a way to enable reCaptcha if your magento2 has not it as default feature.

You will probably need composer version 1 (version 2 did not worked for me)

  1. Enable developer mode
php bin/magento deploy:mode:set developer
  1. Run in your cli
composer require msp/recaptcha
php bin/magento module:enable MSP_ReCaptcha
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:flush
php bin/magento deploy:mode:set production
php bin/magento cache:flush

After that you will find a Security tab on your site configurations page

Hope it helps someone Smiley Happy

View solution in original post

4 REPLIES 4

Re: reCAPTCHA is not supported

Hello @benbengray1dec 

https://docs.magento.com/user-guide/stores/security-google-recaptcha.html

did you check this?

Was my answer helpful? You can accept it as a solution.
150+ professional extensions for M1 & M2 with free lifetime updates!

Re: reCAPTCHA is not supported

Hello

 

Yes of course

I saw so many resources and solutions but non of them are working for me.

The thing is that I do not see any reCAPTCHA in my magento admin panen

 

There is not such page in my admin panel

Stores > Settings > Configuration > Security

 

There is only
Stores > Settings > Configuration > Admin

And There I see security section but there is not any reCAPTCHA option
I see just regular captcha

 

 

Re: reCAPTCHA is not supported

Hello

Any help please?

Re: reCAPTCHA is not supported

Finally I find a way to enable reCaptcha if your magento2 has not it as default feature.

You will probably need composer version 1 (version 2 did not worked for me)

  1. Enable developer mode
php bin/magento deploy:mode:set developer
  1. Run in your cli
composer require msp/recaptcha
php bin/magento module:enable MSP_ReCaptcha
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:flush
php bin/magento deploy:mode:set production
php bin/magento cache:flush

After that you will find a Security tab on your site configurations page

Hope it helps someone Smiley Happy

View solution in original post