cancel
Showing results for 
Search instead for 
Did you mean: 

Error Saving Design Config for one Store

SOLVED

Error Saving Design Config for one Store

We have Magento 2.4.2-p2 installed. We have one store view that we cannot save the Design Config for. We get an error that generally states there is an issue with our file upload settings. This is the only feed back i get for this store and all other stores in the website work fine. I have checked file permission and they seem ok. the file if a logo is changed is uploaded to the temp folder then if saved is moved to the proper stores logo folder. The change to the database never happens however as you get this error then if you refresh the page the old logo is displayed again. Even if you do not make changes to any fields and just click save you get this error. I have looked through all the logs i can fine and tried enabling debugging and i cannot find anything that is output when this issue happens. It smells of some sort of corruption. I checked the commandline and pulled up the show command for the store and i can see the data fields they look comparable to another working store. I am out of ideas here and would like to resolve this as im not sure we could change any of this data for the store if we needed to. Anyone have any thoughts?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error Saving Design Config for one Store

The problem appears to have been a image file that was already in place on the design presumable from before our upgrades. I don't know what about it magento did not like exactly but from what i could tell the error was coming from code that checked the images properties. I was able to simply delete all the images from the design config, save the record then you could apply new images. That error message is trash. Generic message that is used in 3 other places and no log to debug to specify the actual issue. Wasted tons of time on this.

View solution in original post

5 REPLIES 5

Re: Error Saving Design Config for one Store

@dkeymel 

Is it showing 404 error while saving?

If yes, then you can follow this to get the required solution.

https://magento.stackexchange.com/questions/229553/design-configuration-not-saving-showing-404-page-...

 

Problem solved? Click Kudos and "Accept as Solution".
200+ Magento 2 Extensions for Enhanced Shopping Experience.

Re: Error Saving Design Config for one Store

No, it is simply putting up a red box with the error saying there is a problem with our file upload settings (don't have to be uploading a file). The message on the magento UI is the only feedback i have on the issue as no other errors are generated that i can find. i tail the logs as i reproduce the issue and nothing shows up. 

Re: Error Saving Design Config for one Store

Hi all

 

Have same issue after upgrade to 2.4.3. If want change design have following message:

Something is wrong with the file upload settings.

Also nothing in logs. Do you have a solution?

Re: Error Saving Design Config for one Store

The problem appears to have been a image file that was already in place on the design presumable from before our upgrades. I don't know what about it magento did not like exactly but from what i could tell the error was coming from code that checked the images properties. I was able to simply delete all the images from the design config, save the record then you could apply new images. That error message is trash. Generic message that is used in 3 other places and no log to debug to specify the actual issue. Wasted tons of time on this.

View solution in original post

Re: Error Saving Design Config for one Store

@mukipun 

Just posted my solution. IDK if it will be the same for you.