Showing results for 
Search instead for 
Did you mean: 

Magento 2.3.4 installation issue

Magento 2.3.4 installation issue

I am trying to install magento 2.3.4 on a LAMP stack on centos. Php version 7.3 and mysql 5.6. Initially setup was giving a 500 error. I searched google and found a suggestion to remove .htaccess. it worked. Now it gives 404 error for admin page after installation and homepage appears without any css and media. If I put the .htaccess back to root folder of magento, it gives 500 error for both admin and magento store.
Can you please help me find the problem.


Re: Magento 2.3.4 installation issue

Thank you. But where do I find this vendor folder? I am using Lamp stack on centos. and whm/cpanel.

Re: Magento 2.3.4 installation issue

THere is a vendor folder in magento directory but there is no path as mentioned here.

Re: Magento 2.3.4 installation issue

Hi @Toddler,


When facing a 500 error the first thing you should do is to search for your web server error log. When running on apache it can mostly be found in one of these 2 locations:


/var/log/httpd/ -> centos, archlinux ...


/var/log/apache2/ -> debian, ubuntu ...


Hope this can help you! Let me know if you need further assistance.


If issue solved, Click Kudos & Accept as Solution.

LitExtension - #1 Shopping Cart Migration Expert

LitExtension helps store owners and agencies migrate all important data from one eCommerce platform to another accurately, securely and at the highest speed.

Visit website:

Re: Magento 2.3.4 installation issue

If it doesn't give 500 internal server error after removing the .htaccess file, then there must be some PHP version issue or any server configuration is missing.

Re: Magento 2.3.4 installation issue

Please use the below solution

vendor/magento/framework /DB/Adapter/Pdo/Mysql.php

line 1846

after line

case 'smallint':


case 'smallint unsigned':

and after line

case 'int':


case 'int unsigned':

or full method code

protected function _getColumnTypeByDdl($column)
        switch ($column['DATA_TYPE']) {
            case 'bool':
                return Table::TYPE_BOOLEAN;
            case 'tinytext':
            case 'char':
            case 'varchar':
            case 'text':
            case 'mediumtext':
            case 'longtext':
                return Table::TYPE_TEXT;
            case 'blob':
            case 'mediumblob':
            case 'longblob':
                return Table::TYPE_BLOB;
            case 'tinyint':
            case 'smallint':
            case 'smallint unsigned':
                return Table::TYPE_SMALLINT; 
            case 'mediumint':
            case 'int':
            case 'int unsigned':
                re turn Table::TYPE_INTEGER;
            case 'bigint':
                return Table::TYPE_BIGINT;
            case 'datetime':
                return Table::TYPE_DATETIME;
            case 'timestamp':
                return Table::TYPE_TIMESTAMP;
            case 'date':
                return Table::TYPE_DATE;
            case 'float':
                return Table::TYPE_FLOAT;
            case 'decimal':
            case 'numeric':
                return Table::TYPE_DECIMAL;

This worked for me. Hope this works for you as well, Thank You.