Showing results for 
Search instead for 
Did you mean: 

Magento 2 setup:upgrade resulted in multiple issues

Magento 2 setup:upgrade resulted in multiple issues

I took over a developed magento shop and I was trying to solve an issue in which some products would not appear in frontend when navigating to its category (still haven't solved this either btw), so after trying out different solutions without success I tried the following command on the console:


php bin/magento setup:upgrade


after a bunch of blue text my entire shop looks noticeably different


  1. The whole theme of the shop changed. Now, I don't know if my previous theme was deleted and replaced or if it is the same theme but upgraded maybe? Like I said I took over this shop and I never did anything regarding themes, all I know is the current theme name is Solwin FreeGo and I want to go back to the theme I had before.

  2. Default category appears in the front end. The Top Navigation was all over the place. This is the main issue. I was able to fix the design by modifying the Header but the Default category is just there even though I disabled "Included in Menu" on that category in Catalog > Categories > default. No matter what I try, the Default category won't go away.

Default category appears on top navigation 


  1. Category dropdown menus are different.

The Persianas dropdown menu looks like this:


Persianas dropdown menu 


And the Cortinas dropdown menu looks like this:


Cortinas dropdown menu 


All dropdown menus should look like Persianas but WITHOUT the pictures. I have absolutely no idea what happened here. The configurations on both categories look exactly the same. I don't even know where I can control the appereance of these menus.


4. There's 2 Footers. There's the Footer I created and on top of it there's another Footer. I suspect the second Footer was added by whoever was managing the shop before me because it includes an old version of the shop's logo; however, that Footer is not on Content > Footers or on Content > Blocks. If I change the Solwin FreeGo theme, the Footer does dissapear, but it seems like there's no way of keeping the same theme without the Footer. If I go to Stores > Settings > Configuration > FREEGO > Theme Settings > Footer I can change the Footer logo but there's nothing about disabling the footer nor anything about modifying the rest of the footer's content.


Sorry if I'm not being clear enough, I took over this project without even knowing what Magento was. Sometimes I find solutions that require me to go to some file in some folder and add some code, but I don't even know how to access those folders, I don't even have Magento 2 installed, I was just given the credentials to access the Admin. I learned how to reindex on the console using PuTTy but that's about it.


My Magento 2 version is 2.4.3-p1. I'm not sure if I was on a different version before doing setup:upgrade, all I know is that everything went wrong after running that command.


Re: Magento 2 setup:upgrade resulted in multiple issues

Hello @abimaelmon9889 ,


First thing, running setup:upgrade command will not change anything to theme neither it will upgrade any module/theme/magento version.

Also there is no such reference from where we can compare what had changed, you can run below commands for now and make the current work deploy correctly :

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush

try above commands if it fixes the issues which could be part of deployment.

else share more reference that what was working and what is supposed to be working now.



Problem Solved ? Click on 'Kudos' & Accept as Solution ! Smiley Happy

Re: Magento 2 setup:upgrade resulted in multiple issues

Hello @gaurav_harsh1 thank you for your response.


I tried out your solution and this is what happened:


  1. After running setup:upgrade I lose access to both the client and admin page

This is the shop


2. Then I run setup:di:compile and I get the following error when trying to access either client or admin page:


ReflectionException: Class Magento\Framework\App\Http\Interceptor does not exist in /var/www/html/magento2/vendor/magento/framework/Code/Reader/ClassReader.php:28

Stack trace:

#0 /var/www/html/magento2/vendor/magento/framework/Code/Reader/ClassReader.php(28): ReflectionClass->__construct()

#1 /var/www/html/magento2/vendor/magento/framework/ObjectManager/Definition/Runtime.php(54): Magento\Framework\Code\Reader\ClassReader->getConstructor()

#2 /var/www/html/magento2/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php(48): Magento\Framework\ObjectManager\Definition\Runtime->getParameters()

#3 /var/www/html/magento2/vendor/magento/framework/ObjectManager/ObjectManager.php(56): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create()

#4 /var/www/html/magento2/vendor/magento/framework/App/Bootstrap.php(238): Magento\Framework\ObjectManager\ObjectManager->create()

#5 /var/www/html/magento2/pub/index.php(28): Magento\Framework\App\Bootstrap->createApplication()

#6 {main}


3. Then I run setup:static-content:deploy -f and once again I can’t access the pages like in step 1

4. Finally I run cache:flush and nothing changes

Re: Magento 2 setup:upgrade resulted in multiple issues

Seems like your server has some issue with user permission setting or file directory permissions, try running below commands again with permissions : 

chmod -R 777 pub/static/ pub/media/ var/ generated/

rm -rf generated/metadata/ generated/code/ var/cache/mage- var/page_cache/mage- var/view_preprocessed/ var/di/ pub/static/_* pub/static/frontend/ pub/static/adminhtml/

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy -f

php bin/magento c:f

chmod -R 777 pub/static/ pub/media/ var/ generated/

Let me know the results here.

Problem Solved ? Click on 'Kudos' & Accept as Solution ! Smiley Happy

Re: Magento 2 setup:upgrade resulted in multiple issues



I was able to see the shop again after I ran the chmod command (currently there's some issues with the server, somebody else at my job is fixing it so you might or might not be able to access the shop)


Then I did the second command and everything looks the same.


But for some reason I can not longer run setup:upgrade. I get the following messeage in a red box in the console:


'There are no commands defined in the "setup" namespace.'


I did not run the rest of the commands.


Thank you again!




I was able to run setup:upgrade with sudo, and I ran the rest of the commands as well, but the same problem persists.


This is how the top menu should look like without the Default category and with the correct dropdown menu:


Old top menu