cancel
Showing results for 
Search instead for 
Did you mean: 

Problems running Di:compile (no errors)

SOLVED

Problems running Di:compile (no errors)

Hello,

I'm having some issues with my magento, when i Try to make Di:Compile it gets stuck at 1/9 11%.

 

Compilation was started.
Repositories code generation... 1/9 [===>------------------------] 11% < 1 sec 105.0 MiB

 

I'm using magento 2.4.1.

I tryed everything but nothing seems to work for what I've found in the magento comunity forums. There are no errors displayed, hope someone can help me in these.

 

My exception log I get:

 

[2020-12-12 22:35:20] main.CRITICAL: Class Magento\Framework\App\Http\Interceptor does not exist {"exception":"[object] (ReflectionException(code: -1): Class Magento\\Framework\\App\\Http\\Interceptor does not exist at /home/public_html/vendor/magento/framework/Code/Reader/ClassReader.php:24)"} []

The system.log:

 

[2020-12-12 22:35:19] main.ERROR: Warning: include(): Failed opening '/home/public_html/generated/code/Magento//Framework/App/FrontController/Interceptor.php' for inclusion (include_path='/home/public_html/generated/code:/home/public_html/generated/code:/home/public_html/vendor/magento/zendframework1/library:.:/opt/cpanel/ea-php74/root/usr/share/pear') in /home/public_html/vendor/composer/ClassLoader.php on line 444 [] []

 

To mention that this problem happened after a server reboot, since before the compile reached the 100%.

 

Best regards,

Leonel Nunes

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problems running Di:compile (no errors)

@Leo27 

need to check with your hosting

it seems like the process is being killed by the operating system's kernel.

 

Thanks 

View solution in original post

10 REPLIES 10

Re: Problems running Di:compile (no errors)

ok

Re: Problems running Di:compile (no errors)

kindly check your PHP version 
and add a memory_limit command line while running compile 

php -v
php -d memory_limit=4G bin/magento setup:di:compile

kindly Accept as a Solution if this works for you and give kudos Smiley Happy 

Re: Problems running Di:compile (no errors)

Hello and thanks for helping me.

I'm using version 7.4.13.

Already tried that, same issue Smiley Frustrated

 

Any other idea?

 

Best regards,

Leonel Nunes

Re: Problems running Di:compile (no errors)

@Leo27 ,

which hosting you are using?
I had an experience where hosting software kills such processes which consume excess memory or CPU 

Re: Problems running Di:compile (no errors)

Hello Amitsamsukha and thanks for trying to help me.

I have a VPS from OVH, but the weird is that the problem just came after a reboot from the VPS, I don't think that it's the case since I never had this problem before.

 

 

Best Regards,

Leonel Nunes

Re: Problems running Di:compile (no errors)

@Leo27 can you share screenshot for the di:compile command ? 
and the log files for apache? 

Re: Problems running Di:compile (no errors)

Hello, yes, I can, as soon as I have some time I will post here that.

 

Best regards,

Leonel Nunes

Re: Problems running Di:compile (no errors)

Hello Mr amitsamsucka, sorry for sending just now the print screen you asked me.

In the apache logs I can't see nothing in the the time I run Di compile, neither in apache logs and php-fpm logsSmiley Frustrated

 

compile.jpg

Re: Problems running Di:compile (no errors)

@Leo27 

need to check with your hosting

it seems like the process is being killed by the operating system's kernel.

 

Thanks 

View solution in original post