cancel
Showing results for 
Search instead for 
Did you mean: 

The website with id 0 that was requested wasn't found.

The website with id 0 that was requested wasn't found.

Hello I have this problem, can someone help me?
I tried several things but it doesn't work, the pages load normally but the php commands don't work on the SSH terminal

isue.png

Table store

store.png

store_group

store-group.png

store_websitestore-website.png

thanks

5 REPLIES 5

Re: The website with id 0 that was requested wasn't found.

Hello @kleibert_aquino 

 

Run these SQL queries:

SET FOREIGN_KEY_CHECKS=0;
UPDATE `store` SET store_id = 0 WHERE code='admin';
UPDATE `store_group` SET group_id = 0 WHERE name='Default';
UPDATE `store_website` SET website_id = 0 WHERE code='admin';
UPDATE `customer_group` SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN';
SET FOREIGN_KEY_CHECKS=1;

Please take a database backup before running the above queries.

Hope it helps.

---
If you've found my answer useful, please give"Kudos" and "Accept as Solution"

Re: The website with id 0 that was requested wasn't found.

Hey @Meetanshi 

what about: The website with id 1 that was requested wasn't found. Verify the website and try again.

i found this in my exception log after I had installed magento 2.3.5 and try to launch the admin page. my admin page would not launch, it will give me a blank page saying: 

An error has happened during application run. See exception log for details.

 my exception log would also say

{"exception":"[object] (Magento\\Framework\\Exception\\NoSuchEntityException(code: 0): The website with id 1 that was requested wasn't found. Verify the website and try again. at /vendor/magento/module-store/Model/WebsiteRepository.php:110)"} []

Re: The website with id 0 that was requested wasn't found.

 

For fixing the error: 

An error has happened during application run. See exception log for details.

Fix the permissions on the folder where you gave writing permissions:

sudo chown -R daemon:daemon /opt/bitnami/apps/magento/

 

 

Re: The website with id 0 that was requested wasn't found.

Fix the permissions for the folder where you gave writing permissions:

Eg:

sudo chown -R daemon:daemon /opt/bitnami/apps/magento/

Re: The website with id 0 that was requested wasn't found.

Hello I have this problem, can someone help me? I tried several things but it doesn't work, the pages load normally but the php commands