cancel
Showing results for 
Search instead for 
Did you mean: 

watermark not showing on images, Magento 2.3.0

Highlighted

watermark not showing on images, Magento 2.3.0

after update to 2.3.0 version, watermark doesn't show on images.

I've read any single posts about this issue, I've read https://docs.magento.com/m2/ce/user_guide/catalog/product-image-watermarks.htmlhttps://magento.stackexchange.com/questions/190810/watermark-in-magento2-trouble

cleaned the cache, reindex, clean the cache folder

Now the watermarks work fine only for thumbnail images, but not the other ones.

Anyone have suggestions ?

4 REPLIES 4
Highlighted

Re: watermark not showing on images, Magento 2.3.0

@ercolepalmeri 

 

Try the blow command from your Magento root directory to see if that resolves your problem.

 

php bin/magento catalog:image:resize

rm -Rf var/cache/*
rm -Rf var/page_cache/*

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

- Tarandeep
Problem solved?Please give 'Kudos' and accept 'Answer as Solution'.

Re: watermark not showing on images, Magento 2.3.0

any time I add new image to a product I have to execute the image resize commande 

otherwise the image doesn't show

 

how can I solve this?

Highlighted

Re: watermark not showing on images, Magento 2.3.0

Hi @anisagrebi,

By default it product images thumbnails should be auto generated. 

Make sure that you have correct permsions on the server. 

find . -type d -exec chmod 755 {} \; && find . -type f -exec chmod 644 {} \; && chmod u+x bin/magento

chmod -R 0777 var/ pub/ generated/

Use sudo if you have sudo user access. 


I hope it will help you!

----
Problem solved? Click Accept as Solution!
Highlighted

Re: watermark not showing on images, Magento 2.3.0

watermark not showing on images, Magento 2.3.0

 

but watermark show on admin product images

 

please help

 

Thanks in advance