cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to upgrade to Magento 2.4.1 due to laminas-dependency-plugin not working with Composer 2

Highlighted

Unable to upgrade to Magento 2.4.1 due to laminas-dependency-plugin not working with Composer 2

Hi all!

 

I have a Magento 2.3.4 store currently hosted at www.cloudways.com.  I've cloned the server to stage upgrading to v2.4.1, but the Setup Wizard upgrade is failing to proceed past enabling maintenance mode.  My next step was to try upgrading via composer, but I ran into the following:

 

 

rdiasudfza@412349 ~/public_html $ composer update
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading composer repositories with package information
Updating dependencies
Warning from repo.magento.com: You haven't provided your Magento authentication keys. For instructions, visit https://devdocs.magento.com/guides/v2.3/install-gde/prereq/connect-auth.html
    Authentication required (repo.magento.com):
      Username: <snip>
      Password: 
Do you want to store credentials for repo.magento.com in /home/412349.cloudwaysapps.com/rdiasudfza/.config/composer/auth.json ? [Yn] 
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laminas/laminas-dependency-plugin[1.0.0, ..., 1.0.4] require composer-plugin-api ^1.1 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
    - magento/product-community-edition 2.4.1 requires laminas/laminas-dependency-plugin ^1.0 -> satisfiable by laminas/laminas-dependency-plugin[1.0.0, ..., 1.0.4].
    - Root composer.json requires magento/product-community-edition 2.4.1 -> satisfiable by magento/product-community-edition[2.4.1].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

If I'm not mistaken, it's stuck because laminas/laminas-dependency-plugin doesn't seem to support composer 2?  The software stack on cloudways has Composer 2.0.2 pre-installed and it can't be downgraded.

 

Is it correct that I assume laminas/laminas-dependency-plugin is a dependency for magento/product-community-edition?  It's required regardless?

 

I see there's a bug report for this on the laminas project: https://github.com/laminas/laminas-dependency-plugin/issues/21

 

What I don't understand is I can't seem to find any other reports of others having issues upgrading?  Am I missing something basic?

 

Thanks in advance!

 

2 REPLIES 2
Highlighted

Re: Unable to upgrade to Magento 2.4.1 due to laminas-dependency-plugin not working with Composer 2

Hi, I had the same issue. for temporary solutions, I just downloaded the last composer.phar 1 version and stored in Magento root catalog. `php composer.phar install` works like before. Smiley Happy 

Highlighted

Re: Unable to upgrade to Magento 2.4.1 due to laminas-dependency-plugin not working with Composer 2

If you face this issue.
And using version want to upgrade to version 2.4.1 with composer 2, it will not work.
Magento 2 probably still not ready for composer 2.
Please look this issue.
https://github.com/magento/magento2/issues/30741

Probably summary is use Composer 1.
This could help 

wget https://github.com/composer/composer/releases/download/1.10.17/composer.phar

mv composer.phar /usr/local/bin/composer

chmod +x /usr/local/bin/composer