cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade from 2.3.4 to 2.3.5 or 2.4 errors

Upgrade from 2.3.4 to 2.3.5 or 2.4 errors

I'm trying to upgrade a site from 2.3.4 to either 2.3.5 or 2.4. but It won't pass the readiness check.

If I try to upgrade to 2.3.5 It just says there are conflicts but doesn't tell me what & if I try to upgrade to 2.4 it tells me that my php version is either too high or too low.

I have tried php 7.1 through 7.4 both in the front end & backend for both upgrades but no joy & also tried upgrading via ssh.

It would appear that its because composer needs updating but when  try to update it via ssh I get this error message.

 

-bash-4.2$ composer require magento/composer-root-update-plugin=~1.0 --no-update

 

PHP Warning:  Unsupported declare 'strict_types' in .................................../vendor/magento/inventory-composer-installer/src/Plugin.php on line 6

 

Warning: Unsupported declare 'strict_types' in .................................../vendor/magento/inventory-composer-installer/src/Plugin.php on line 6

PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in ................................../vendor/magento/inventory-composer-installer/src/Plugin.php on line 55

 

Parse error: syntax error, unexpected ':', expecting ';' or '{' in .................................../vendor/magento/inventory-composer-installer/src/Plugin.php on line 55

 

A search for this error again suggests that its because Im not using the correct php version but  again I have tried php 7.1 through 7.4 ( I know the php version is correct by using php -v)

 

Updated other sites no problem but this is the only site which had the demo data installed.

2 REPLIES 2
Highlighted

Re: Upgrade from 2.3.4 to 2.3.5 or 2.4 errors

Hello @anim8design 

 Check your PHP version is compatible or not

follow the link given below for a command-line upgrade

 

https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html#upgrade-cli-script

Thank You.

 

Highlighted

Re: Upgrade from 2.3.4 to 2.3.5 or 2.4 errors

You can check with following extension just your reference, curtain wonderland coupon code  Thank you.