cancel
Showing results for 
Search instead for 
Did you mean: 

URL could not be accessed: HTTP/1.1 403 Forbidden

Highlighted

URL could not be accessed: HTTP/1.1 403 Forbidden

I have created an extension.  There has been a request to make a commercial version of the extension.  I have requested and been given access to the Magento cloud test environment.  However, I cannot get the test environment to install.


Why am I getting the below error in the cloud test environment?


Building application 'mymagento' (runtime type: php:7.2, tree: 16a95a5)
Generating runtime configuration.

Moving the application to the output directory
Prewarming composer cache.
W: Failed to pre-download 320 packages

Found a `composer.json`, installing dependencies.
W: Loading composer repositories with package information
W: Installing dependencies (including require-dev) from lock file
W: Package operations: 435 installs, 0 updates, 0 removals
W: - Installing magento/magento-composer-installer (0.1.13): Loading from cache
W: - Installing zendframework/zend-stdlib (2.7.7): Loading from cache
W: - Installing zendframework/zend-hydrator (1.1.0): Loading from cache
W: - Installing psr/container (1.0.0): Loading from cache
W: - Installing container-interop/container-interop (1.2.0): Loading from cache
W: - Installing zendframework/zend-validator (2.11.1): Loading from cache
W: - Installing zendframework/zend-escaper (2.6.0): Loading from cache
W: - Installing zendframework/zend-uri (2.7.0): Loading from cache
W: - Installing zendframework/zend-servicemanager (2.7.11): Loading from cache
W: - Installing zendframework/zend-loader (2.6.0): Loading from cache
W: - Installing zendframework/zend-http (2.8.4): Loading from cache
W: - Installing psr/http-message (1.0.1): Loading from cache
W: - Installing zendframework/zend-diactoros (1.8.6): Loading from cache
W: - Installing zendframework/zend-psr7bridge (0.2.2): Loading from cache
W: - Installing zendframework/zend-filter (2.9.1): Loading from cache
W: - Installing zendframework/zend-inputfilter (2.10.0): Loading from cache
W: - Installing zendframework/zend-form (2.13.0): Loading from cache
W: - Installing zendframework/zend-eventmanager (2.6.4): Loading from cache
W: - Installing zendframework/zend-console (2.7.0): Loading from cache
W: - Installing zendframework/zend-mvc (2.7.15): Loading from cache
W: - Installing zendframework/zend-math (2.7.1): Loading from cache
W: - Installing zendframework/zend-crypt (2.6.0): Loading from cache
W: - Installing zendframework/zend-code (3.3.1): Loading from cache
W: - Installing tedivm/jshrink (v1.3.1): Loading from cache
W: - Installing symfony/process (v4.1.11): Loading from cache
W: - Installing symfony/polyfill-mbstring (v1.11.0): Loading from cache
W: - Installing symfony/console (v4.1.11): Loading from cache
W: - Installing oyejorge/less.php (v1.7.0.14): Loading from cache
W: - Installing psr/log (1.1.0): Loading from cache
W: - Installing monolog/monolog (1.24.0): Loading from cache
W: - Installing magento/zendframework1 (1.14.1): Loading from cache
W: - Installing symfony/finder (v4.2.4): Loading from cache
W: - Installing symfony/polyfill-ctype (v1.11.0): Loading from cache
W: - Installing symfony/filesystem (v4.2.4): Loading from cache
W: - Installing seld/phar-utils (1.0.1): Loading from cache
W: - Installing seld/jsonlint (1.7.1): Loading from cache
W: - Installing justinrainbow/json-schema (5.2.8): Loading from cache
W: - Installing composer/xdebug-handler (1.3.2): Loading from cache
W: - Installing composer/spdx-licenses (1.5.1): Loading from cache
W: - Installing composer/semver (1.5.0): Loading from cache
W: - Installing composer/ca-bundle (1.1.4): Loading from cache
W: - Installing composer/composer (1.8.4): Loading from cache
W: - Installing colinmollenhour/credis (1.10.0): Loading from cache
W: - Installing colinmollenhour/php-redis-session-abstract (v1.4.1): Loading from cache
W: - Installing magento/framework (102.0.1): Downloading
W:
W: [Composer\Downloader\TransportException]
W: The 'https://repo.magento.com/archives/magento/framework/magento-framework-102.0.1.0.zip' URL could not be accessed: HTTP/1.1 403 Forbidden
W:
W:
W: install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...
W:

E: Error building project: `composer` could not be run. Aborted build.
E: Error: Unable to build application, aborting.

7 REPLIES 7
Highlighted

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

Hi,

   Check URL https://devdocs.magento.com/guides/v2.3/cloud/requirements/cloud-requirements.html to install Magento Commerce Cloud Project.

   As you are getting forbidden error for the Repo URL so check if you had followed these steps properly

I hope this will resolve your issue.

Thanks

 

Highlighted

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

This happens to me, I am not installing the Cloud version, just the normal EE. 

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

Even I am facing same issue in the magento-invitation module while composer update:

 

- Installing magento/module-invitation (100.3.3-p1): Downloading (connecting...)

[Composer\Downloader\TransportException]
The 'https://repo.magento.com/archives/magento/module-invitation/magento-module-invitation-100.3.3.0-patc...' URL could not be accessed: HTTP/1.1 403 Forbidden

 

Highlighted

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

We are experiencing this issue too, with seemingly random packages.

Are you using 'shared access' and access keys on a different account from the 'main' account?

 

I think shared access is broken since the maintenance a couple of weekends ago. We can get most packages fine, but random ones like module-worldpay and module-wee-staging come back with 403 errors.

 

If anyone has a fix or update I would be very pleased to hear it.

Highlighted

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

Confirmed this is happening on 2.3.3. 

Highlighted

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

Hi,

I have since tested with our main account and the errors are the same there, so the 'shared access' is not the issue.

It happens with a seemingly random selection of modules, for example module-worldpay is denied, module-braintree is fine.

I am currently working through all the modules compiling a list of those affected.

Magento support is looking into it but have not been very helpful so far.

Regards

Hans

Highlighted

Re: URL could not be accessed: HTTP/1.1 403 Forbidden

Hi,

This issue seems to have resolved itself for us in the last 24 hours - our main account is now able to access all repos again. Will test using the shared access accounts in a day or two.

Regards

Hans