cancel
Showing results for 
Search instead for 
Did you mean: 

Error upgrading Magento 2.3.5-p1 to 2.4.0

Highlighted

Error upgrading Magento 2.3.5-p1 to 2.4.0

Hello. I am trying to upgrade Magento to 2.4.0 from 2.3.5-p1, and am getting the following error(s) which I require assistance with:

Problem 1
    - magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.16 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.17 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 100.1.18 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.10 requires php ~7.0.13|~7.1.0|~7.2.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 101.0.11 requires php ~7.0.13||~7.1.0||~7.2.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.22) does not satisfy that requirement.
    - magepal/magento2-edit-order-email 1.1.2 requires magento/framework 100.0.*|100.1.*|101.0.*|102.0.* -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 100.1.18, 102.0.2, 101.0.8, 102.0.1, 100.1.17, 102.0.0, 101.0.7, 100.1.16, 101.0.6, 100.1.15, 100.1.14, 101.0.5, 101.0.4, 100.1.13, 101.0.3, 100.1.12, 100.0.20, 101.0.2, 100.1.11, 100.1.10, 101.0.1, 100.0.19, 101.0.0, 100.0.18, 100.1.9, 100.1.8, 100.0.17, 100.0.16, 100.1.7, 100.1.6, 100.0.15, 100.1.5, 100.0.14, 100.1.4, 100.0.13, 100.1.3, 100.1.2, 100.0.12, 100.1.1, 100.0.11, 100.0.10, 100.1.0, 100.0.9, 100.0.8, 100.0.7, 100.0.6, 100.0.5, 100.0.4, 100.0.3, 100.0.2].
    - magepal/magento2-edit-order-email 1.1.2 requires magento/framework 100.0.*|100.1.*|101.0.*|102.0.* -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 100.1.18, 102.0.2, 101.0.8, 102.0.1, 100.1.17, 102.0.0, 101.0.7, 100.1.16, 101.0.6, 100.1.15, 100.1.14, 101.0.5, 101.0.4, 100.1.13, 101.0.3, 100.1.12, 100.0.20, 101.0.2, 100.1.11, 100.1.10, 101.0.1, 100.0.19, 101.0.0, 100.0.18, 100.1.9, 100.1.8, 100.0.17, 100.0.16, 100.1.7, 100.1.6, 100.0.15, 100.1.5, 100.0.14, 100.1.4, 100.0.13, 100.1.3, 100.1.2, 100.0.12, 100.1.1, 100.0.11, 100.0.10, 100.1.0, 100.0.9, 100.0.8, 100.0.7, 100.0.6, 100.0.5, 100.0.4, 100.0.3, 100.0.2].
    - Can only install one of: magento/framework[102.0.5-p2, 103.0.0].
    - Can only install one of: magento/framework[102.0.4-p2, 103.0.0].
    - Can only install one of: magento/framework[102.0.5, 103.0.0].
    - Can only install one of: magento/framework[102.0.3-p1, 103.0.0].
    - Can only install one of: magento/framework[102.0.4, 103.0.0].
    - Can only install one of: magento/framework[102.0.3, 103.0.0].
    - Can only install one of: magento/framework[103.0.0, 102.0.5].
    - magento/product-community-edition 2.4.0 requires magento/framework 103.0.0 -> satisfiable by magento/framework[103.0.0].
    - Installation request for magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].
    - Installation request for magepal/magento2-edit-order-email 1.1.2 -> satisfiable by magepal/magento2-edit-order-email[1.1.2].

Can anyone advise how to proceed?

Thanks in advance!

10 REPLIES 10
Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

Im not very experienced, so better advice from others may follow.

I would say Check in your composer.json file

In there will be "phpunit/phpunit" listed with a version number after,

which is Version Constrain / limiting its upgrade, and causing the error message above "these conflict with your requirements or minimum-stability."

So you may have to change the version number. 

Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

I have set this manually to

 

  "phpunit/phpunit": "^9",

Having referred to

 

https://itcruncher.blogspot.com/2020/09/upgrade-magento-2.3.5-p1-to-magento-2.4.html

 

Still no joy.

Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

Hello @Pistle1992da70 

 

Check below solution, it will work for you :

https://community.magento.com/t5/Magento-2-x-Version-Upgrades/2-3-5-P1-to-2-4-0-upgrade-Fails/td-p/4...

 

Let us know if it works Smiley Happy

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !
Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

Already attempted that.

 

I'm currently have this error:

 

  Problem 1
    - magento/magento-coding-standard 1.0.2 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
    - magento/magento-coding-standard 1.0.1 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
    - magento/magento-coding-standard 1.0.0 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
    - magento/magento-coding-standard 1.0.2 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
    - Installation request for magento/magento-coding-standard ~1.0.0 -> satisfiable by magento/magento-coding-standard[1.0.0, 1.0.1, 1.0.2].

Here is my composer.json:

 

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "config": {
        "preferred-install": "dist",
        "sort-packages": true
    },
    "require": {
        "dompdf/dompdf": "^0.8.3",
        "friendsofphp/php-cs-fixer": "^2.16.0",
        "hexasoft/module-fraudlabspro": "^2.1",
        "magento/composer-root-update-plugin": "~1.0",
        "magento/magento2-functional-testing-framework": "^3.0",
        "magento/product-community-edition": "2.4.0",
        "magepal/magento2-edit-order-email": "1.1.2",
        "mageplaza/module-core": "^1.4",
        "mageplaza/module-smtp": "^4.0.0",
    },
    "require-dev": {
        "allure-framework/allure-phpunit": "~1.2.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento-coding-standard": "~1.0.0",
        "pdepend/pdepend": "~2.7.1",
        "phpmd/phpmd": "^2.8.0",
        "phpstan/phpstan": ">=0.12.3 <=0.12.23",
        "phpunit/phpunit": "^9",
        "sebastian/phpcpd": "~5.0.0",
        "squizlabs/php_codesniffer": "~3.5.4"
    },
    "conflict": {
        "gene/bluefoot": "*"
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/",
            "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
        },
        "psr-0": {
            "": [
                "app/code/",
                "generated/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "version": "2.4.0",
    "minimum-stability": "stable",
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },
        "craftyclicks": {
            "type": "git",
            "url": "https://github.com/craftyclicks/magento2.git"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}
Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

Hello @GTLTD 

 

Change this line from your composer.json

"squizlabs/php_codesniffer": "~3.5.4"

to :

"squizlabs/php_codesniffer": "3.3.0"

and run composer update after that.

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !
Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0


@gaurav_harsh1 wrote:

Hello @GTLTD 

 

Change this line from your composer.json

"squizlabs/php_codesniffer": "~3.5.4"

to :

"squizlabs/php_codesniffer": "3.3.0"

and run composer update after that.


Thank you! I now have 2.4.0 installed. I do however have another issue. When running "php bin/magento setup:upgrade" I get the following message:

 

Reading [Magento Install Directory]/public_html/composer.json
Loading config file [Magento Install Directory]/public_html/composer.json
Loading config file [Magento Install Directory]/public_html/auth.json
Reading [Magento Install Directory]/public_html/auth.json
Failed to initialize global composer: Composer could not find the config file: [Magento Install Directory]/public_html/var/composer_home/composer.json
To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section
Reading [Magento Install Directory]/public_html/vendor/composer/installed.json
Reading [Magento Install Directory]/public_html/composer.lock
Checking for "magento/composer-root-update-plugin: 1.0.0" for the Web Setup Wizard...
Reading [Magento Install Directory]/public_html/var/vendor/magento/composer-root-update-plugin/composer.json
Loading config file [Magento Install Directory]/public_html/var/vendor/magento/composer-root-update-plugin/composer.json
No Web Setup Wizard update needed for magento/composer-root-update-plugin; version 1.0.0 is already in [Magento Install Directory]/public_html/var.

 

What on earth does this mean?

Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

@GTLTD 

 

Just create a file at :

[Magento Install Directory]/public_html/var/composer_home/composer.json

 

and add only this content in that :

{}

Hope it will work !

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !
Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

ote: please check php7.4 version and elasticsearch installed.

First take to older version website backup and after your run direct magento 2.4.0 version.

Magento Open Source:

composer require magento/product-community-edition=2.4.0 --no-update

Magento Commerce:

composer require magento/product-enterprise-edition=2.4.0 --no-update

 

UPDATE:-

I will explain more in how to update latest magento version (2.4 at the moment):.

composer require magento/product-community-edition=2.4.0 --no-update

composer update

If you are running Magento 2 commerce the command will be slightly different:

composer require magento/product-enterprise-edition=2.4.0 --no-update

composer update

Replace 2.4 with the latest M2 version.

When it is completed, run another SSH command and upgrade the Magento database:

php bin/magento setup:upgrade

After that you will want to recompile if you are in production mode:

php bin/magento deploy:mode:set production

You’ve successfully performed a Magento 2 upgrade! Now go to the frontend and backend and check everything.

Highlighted

Re: Error upgrading Magento 2.3.5-p1 to 2.4.0

 


@gaurav_harsh1 wrote:

@GTLTD 

 

Just create a file at :

[Magento Install Directory]/public_html/var/composer_home/composer.json

 

and add only this content in that :

{}

Hope it will work !


Hello.

 

Thanks. Have done that, but still getting the same error when running php bin/magento setup:upgrade?